Segunda, 16/July/2018
Programando {Init:}
[ Novas Menssagens · Membros · Regras do Forum · Busca · RSS ]
  • Page 1 of 1
  • 1
Forum moderator: constantine  
Forum » Programação » Logica de Programação / Portugol » Usando Portugol (Alguns Exemplos testados e funcionando)
Usando Portugol
constantineDate: Quarta, 31/August/2011, 20:13:33 | Message # 1
Generalissimo
Group: Administrators
Messages: 9
Reputation: 0
Status: Offline
Vamos Usar essse Topico para postar exemplos feitos no Portugol e que funcionam sem erros.

algoritmo "Dia da semana"
// Função : Ao Digitar um numero entre 1 e 7 ele diz o dia da semana
// Autor :
// Data : 30/8/2011
// Seção de Declarações
var
n1:inteiro
inicio
// Seção de Comandos
escreva ("Digite um numero")
leia(n1)
escolha (n1)
caso 1
escreva ("Domingo")
caso 2
escreva ("Segunda")
caso 3
escreva ("Terça")
caso 4
escreva ("Quarta")
caso 5
escreva ("Quinta")
caso 6
escreva ("Sexta")
caso 7
escreva ("Sabado")
outrocaso
escreva ("Nao é um dia da semana")

fimescolha

fimalgoritmo


Você pode ter todo dinheiro do mundo,mas há algo que você jamais ira comprar,UM DINOSSAURO!
By: Homer Simpson
 
constantineDate: Quarta, 31/August/2011, 23:38:20 | Message # 2
Generalissimo
Group: Administrators
Messages: 9
Reputation: 0
Status: Offline
algoritmo "imc"
// Função :calcula o imc usando como base a altura e o peso da pessoa e
// a informa de sua situação conforme a tabela da oms.
// Autor : Joao Machado
// Data : 30/8/2011
// Seção de Declarações
var
p,h,i:real
inicio
// Seção de Comandos
escreva ("Digite sua altura ")
leia(h)
escreva ("Digite o seu Peso ")
leia(p)
i <- p / (h^2)
escreval ("O seu IMC é :" ,i)
se (i<= 18) entao
escreval ("Abaixo do Peso")
senao
se (i>18) e (i<=25) entao
escreval ("Voce esta no peso ideal")
senao
se (i>25) e (i<=30) entao
escreval ("Voce esta com sobrepeso")
senao
escreval ("Voce esta obeso.")

fimse
fimse
fimse
fimalgoritmo


Você pode ter todo dinheiro do mundo,mas há algo que você jamais ira comprar,UM DINOSSAURO!
By: Homer Simpson
 
Forum » Programação » Logica de Programação / Portugol » Usando Portugol (Alguns Exemplos testados e funcionando)
  • Page 1 of 1
  • 1
Search:

Copyright MyCorp © 2018
Powered by uCoz